Manage Mikrotik LAB Router via Winbox

This lesson will guide you to create GNS3 lab for Mikrotik router and manage those virtual routers via Winbox.

If you haven’t read my previous blog about how to add Mikrotik Router in GNS3, I would request you to read from here how-to-add-mikrotik-router-in-gns3 prior to jump into this lesson.

So, this tutorial is actually the second part of adding Mikrotik Router in GNS3.

We added two Mikrotik router in GNS3 for our LAB.

Configuration steps:

At first, we will create a loopback interface on our Windows machine.

Create loopback interface:
  • Type hdwwiz.exe on search box and enter
Type hdwwiz
  • Select the option: Install the hardware that I manually select from a list (Advanced)
Install the hardware manually
  • Select ‘Network Adapters’
‘Network Adapters’
  • Select ‘Microsoft’ from Manufacturer column and then select ‘Microsoft-KM-Test Loopback adapter’ under Model.
Select Microsoft and add Microsoft Loopback Adapter
  • Click finish.
Click ‘Finish’
Configure Cloud:

Now we will configure cloud.

  • Drag the cloud from left menu ‘Installed and Available appliances’
Drag Cloud from Installed and Available appliances
  • Right click on cloud and select configure
Configuring Cloud Interface
  • Add Interface on Cloud.
Adding interface for Cloud Configuration
Configure IP address:
  • Assign IP address 10.0.0.1 and subnet mask 255.255.255.0
Assign IP address on Loopback interface
  • Right click on router and select console to access router
Console access to Mikrotik Router
  • Configure IP on our edge router.

/ip address add address=10.0.0.2/24 interface=ether5

Assigning IP Address on Edge Router
  • We can now connect our Mikrotik router via  Winbox now.
Router IP and MAC address are showing on Winbox

Bonus Tips:

Here’s a bonus tips for your. You may wonder how you can connect your 2nd router or 3rd or any other router behind your edge router.

For this, we will configure a feature called RoMON. RoMON stands for “Router Management Overlay Network”. It’s a built-in feature of RouterOS.

Type a single command on both router to enable RoMON feature. Access both router via console and type the below command on Mikrotik router terminal:

/tool romon set enabled=yes

Command in terminal to enable RoMON

Now we will see how we can connect our 2nd router behind edge router.

  • Open Winbox.
  • Select your router IP address and click this button: “Connect to RoMON”
Connect 2nd router via 1st router with RoMON feature
  • After clicking on ‘Connect to RoMON’ button, 2nd router IP and MAC address will appear on Winbox RoMON Neighbors:
After clicking ‘Connect to RoMON’
  • Now select 2nd router IP or MAC and connect.
Both router connect via Winbox

Follow the steps and you will able to create GNS3 LAB and manage your Mikrotik router via Winbox.

Video Tutorial:

 

 

Leave a Reply

Your email address will not be published. Required fields are marked *